5.4.5. ジョブレポート[EXTENSION]

別途EXTENSIONを購入することにより、フレーム、ネット、ジョブの稼働履歴や、統計情報を表示することができます。

5.4.5.1. ジョブレポートの概要

ジョブレポートでは、過去に実行したジョブスケジュールの起動、終了情報を千手データベースサーバーに蓄積し、起動/終了時刻や実行時間をガントチャート、リスト、グラフで表示します。

[稼働履歴]タブでは、フレーム、ネット及びジョブの実行開始時刻、終了時刻をガントチャート、リストで表示します。

[統計情報]タブでは、フレーム、ネット、ジョブの直近の稼働履歴から実行時間をグラフで表示します。

5.4.5.2. ジョブレポートの画面概要

ジョブレポート画面は、メニュー、ツールバー、ステータスバー、タブ、選択ジョブ/ネット情報、アウトプットビューを持ちます。タブには、[稼働履歴]タブ・[統計情報]タブがあります。

また、[稼働履歴]タブには、ツリー表示部があります。

アウトプットビューはドッカブルバーであり、位置及びサイズを変更することができます。

アウトプットビューについては、千手ブラウザと同じ機能です。詳しくは 千手ブラウザの基本構成 を参照して下さい。

5.4.5.2.1. ジョブレポート([稼働履歴]タブ)

下記の図に、ジョブレポートの[稼働履歴]タブの概要を示します。

ツリー表示部で選択された実行システムの稼働履歴情報が、ガントチャートで表示されます。

../../_images/image513.jpg

図 5.463 ジョブレポート[稼働履歴]タブ(ガントチャート)

ジョブレポートの[稼働履歴]タブのガントチャート部で表示される内容を下記の表に示します。

表 5.418 ガントチャートの表示内容

項目

内容

ジョブ/ネット名

ジョブ/ネットの名称を表示します。

ガントチャート

ジョブ/ネット毎に、実際に稼働したグラフが表示されます。表示しているのがフレームやネットの場合は開始時刻と終了時刻にそれぞれマークが表示されています。ジョブの場合はにはありません。

それぞれの終了状態を色で示しています。表示色は以下のとおりです。

  • フレーム/ネット表示色

    正常終了:青色

    スキップ終了:濃い灰色

    まだ終了していない未定の状態:黒色

  • ジョブ表示色

    正常終了:青色

    異常終了:赤色

    スキップ終了:濃い灰色

時間バーは画面右上部の時間/分選択ラジオボタンでスケールを切り替えることができます。

図 5.464 のようにマウスをフレームの上に置くと、ツールチップウィンドウが表示されます。ツールチップウィンドウには、マウス下のフレーム名が表示されます。

../../_images/04_JobReport_RunHistory_GanttChart_Tooltip_Window.jpg

図 5.464 ジョブレポート[稼働履歴]タブ(ガントチャート)のツールチップウィンドウ

また、この画面からジョブ/ネットの終了情報をプルダウンリストをガントチャートからリストに切り替えることができます。ジョブレポートの[稼働履歴]タブのリスト部で表示される内容は、ツリービューでシステム選択時と、システム以外を選択した時で異なります。

画面左上部のプルダウンリストから「リスト」を選択して表示されるジョブレポートの[稼働履歴]タブ(リスト)システム選択時の概要を下記の図に示します。

../../_images/image5141.jpg

図 5.465 ジョブレポート[稼働履歴]タブ(リスト)システム選択

ツリービューでシステムを選択した時のリストに表示される内容を下記の表に示します。

表 5.419 リストの表示内容(システム選択時)

項目

内容

フレーム名

フレームの名称を表示します。

開始日時

開始日時を表示します。

終了日時

終了日時を表示します。

状態

終了状態を表示します。

ジョブレポートの[稼働履歴]タブ(リスト)のツリービューでフレーム/ネットを選択した時の概要を下記の図に、表示される内容を下記の表に示します。

../../_images/image5151.jpg

図 5.466 ジョブレポートの[稼働履歴]タブ(リスト)システム以外選択

表 5.420 リストの表示内容(フレーム、ネット選択時)

項目

内容

ジョブ/ネット名

ジョブ/ネットの名称を表示します。

種類

ジョブ、ネット、分岐ジョブの種別を表示します。

親ネット名

親ネット名を表示します。

開始日時

開始日時を表示します。

終了日時

終了日時を表示します。

状態

終了状態を表示します。

終了コード

終了コードを表示します。(種類がジョブの時のみ)

動作環境名

実行した動作環境名称を表示します。(種類がジョブの時のみ)

実行ノード

実行したノードを表示します。(種類がジョブの時のみ)ジョブに動作環境(千手センサー指定)が指定されている場合は、「ノードID[プローブノードID](ノード名[プローブノード名])」の書式でプローブノードも併せて表示されます。

それぞれのリストは終了状態で色分けして表示されます。表示色は以下のとおりです。

  • フレーム/ネット表示色

    正常終了:青色

    スキップ終了:濃い灰色

    まだ終了していない未定の状態:黒色

  • ジョブ表示色

    正常終了:青色

    異常終了:赤色

    スキップ終了:濃い灰色

    まだ終了していない未定の状態:黒色

5.4.5.2.2. ジョブレポート([統計情報]タブ)

ジョブレポートの[統計情報]タブの概要を下記の図に、内容を下記の表に示します。

../../_images/image5161.jpg

図 5.467 ジョブレポート[統計情報]タブ

表 5.421 ジョブレポート[統計情報]タブ

項目

内容

「表示期間」フィールド

統計情報に表示されているデータの期間を表示します。

「運用日付」フィールド

選択された点の運用日付を表示します。

「実行システム名」フィールド

選択された点の実行システム名を表示します。

「フレーム名」フィールド

選択された点のフレーム名を表示します。

「親ネット名」フィールド

選択された点の親ネット名を表示します。

「ジョブ/ネット名」フィールド

選択された点のジョブ/ネット名を表示します。

「状態」フィールド

選択された点の終了状態を表示します。

「実行動作環境名」フィールド

選択された点の実行動作環境名を表示します。実行動作環境(千手センサー指定)の場合は、プローブノードIDを()内に出力します。

「種類」フィールド

選択された点の種類を表示します。

「ノード」フィールド

選択された点の実行されたノード名を表示します。

「開始日時」フィールド

選択された点の実行開始日時を表示します。

「終了日時」フィールド

選択された点の実行終了日時を表示します。

「終了コード」フィールド

選択された点の終了コード表示します。(種類がジョブの時のみ)

5.4.5.3. ジョブレポートのメニュー

ジョブレポートのメニューを下記の図に示します。

メニューには、[ファイル]メニュー・[編集]メニュー・[表示]メニュー・[ヘルプ]メニューがあります。

../../_images/image5171.jpg

図 5.468 ジョブレポートのメニュー

5.4.5.3.1. ジョブレポート([ファイル]メニュー)

ジョブレポートの[ファイル]メニューを下記の図に、内容を下記の表に示します。

../../_images/image5181.jpg

図 5.469 ジョブレポートの[ファイル]メニュー

表 5.422 ジョブレポートの[ファイル]メニュー

項目

内容

ジョブレポート定義

ジョブレポート定義の選択ダイアログを表示します。

表示条件の選択

ジョブレポートで表示するフレーム、ネット、ジョブを指定するジョブレポート表示条件ダイアログを表示します。

送る→ファイル

現在稼働履歴タブ、統計情報タブに表示しているデータの内容を以下の形式でファイルに書き込みます。
  • テキスト(スペース区切り):各項目はスペースで区切られています。

  • テキスト(タブ区切り):各項目はタブで区切られています。

  • CSV(カンマ区切り):各項目はカンマで区切られています。

  • HTML:HTML形式で出力されます。

送る→メール受信者

現在稼働履歴タブ、統計情報タブに表示しているデータの内容をテキスト形式ファイルにし、メールに添付して送信します。前提条件として、Microsoft ExchangeなどのMAPI(Message Application Program Interface)と互換性のあるメールシステムの設定が必要です。

印刷

現在稼働履歴タブ、統計情報タブに表示しているデータの内容をテキスト形式で印刷します。

アウトプットビューの印刷

アウトプットビューの内容をテキスト形式で印刷します。

プリンタの設定

プリンタ設定用のコモンダイアログを表示します。

閉じる

ジョブレポートウィンドウを閉じます。

5.4.5.3.2. ジョブレポート([編集]メニュー)

ジョブレポートの[編集]メニューを下記の図に、内容を下記の表に示します。

../../_images/image5191.jpg

図 5.470 ジョブレポートの[編集]メニュー

表 5.423 ジョブレポートの[編集]メニュー

項目

内容

切り取り

常に選択不可になっています。

コピー

現在選択されているジョブ、ネットの情報をクリップボードにテキスト形式でコピーします。

貼り付け

常に選択不可になっています。

削除

常に選択不可になっています。

すべて選択

常に選択不可になっています。

検索

稼働履歴タブにおいてジョブ名、ネット名、フレーム名を検索し、表示します。

数値データをコピー

現在稼働履歴タブ、統計情報タブで表示されているデータをクリップボードにテキスト形式でコピーします。

5.4.5.3.3. ジョブレポート([表示]メニュー)

ジョブレポートの[表示]メニューを下記の図に、内容を下記の表に示します。

../../_images/image5201.jpg

図 5.471 ジョブレポートの[表示]メニュー

表 5.424 ジョブレポートの[表示]メニュー

項目

内容

上位ネットへ

上位ネットへ移動します。左のツリービューも連動します。上位ネットが確定できる場合のみ有効になります。統計情報タブでは常に選択不可になっています。

下位ネットへ

下位ネットへ移動します。左のツリービューも連動します。1つのネットが選択されている場合のみ有効になります。統計情報タブでは常に選択不可になっています。

ツールバー

ツールバーの表示/非表示の切り替えを行います。

アウトプットビュー

アウトプットビューの表示/非表示の切り替えを行います。

ステータスバー

ステータスバーの表示/非表示の切り替えを行います。

ツールバーの設定

ツールバーの設定を行うツールバー設定ダイアログを表示します。

フォントの設定

フォントの設定ダイアログを表示します。

最新の情報に更新

ジョブレポートの内容を最新の情報に更新します。

5.4.5.3.4. ジョブレポート([ヘルプ]メニュー)

ジョブレポートの[ヘルプ]メニューを下記の図に、内容を下記の表に示します。

../../_images/image5211.jpg

図 5.472 ジョブレポートの[ヘルプ]メニュー

表 5.425 ジョブレポートの[ヘルプ]メニュー

項目

内容

バージョン情報

千手ブラウザのバージョンを表示します。

5.4.5.4. ジョブレポートのツールバー

ジョブレポートのデフォルトのツールバーを下記の表に示します。

ツールバーに表示する項目は、「表示メニュー」の「ツールバーの設定」を選択して出てくるダイアログで、自由に変更することができます。

表 5.426 ジョブレポートのツールバー

アイコン

名前

アクション

../../_images/image5221.jpg

表示条件の選択

ジョブレポート表示条件選択ダイアログ を表示します。

../../_images/image5231.jpg

検索

フレーム、ネット、ジョブ名称の検索を行い表示します。

../../_images/image5241.jpg

最新の情報に更新

ジョブレポートの内容を最新の情報に更新します。

5.4.5.5. ジョブレポートのコンテキストメニュー

ジョブレポートのコンテキストメニューを下記の図に、内容を下記の表に示します。

コンテキストメニューは稼働履歴タブのリスト形式で表示したときのネット、ジョブを選択したときに表示されます。

../../_images/image525.jpg

図 5.473 ジョブレポートのコンテキストメニュー

表 5.427 ジョブレポートのコンテキストメニュー

項目

内容

上位ネットへ

上位ネットへ移動します。左のツリービューも連動します。上位ネットが確定できる場合のみ有効になります。統計情報タブでは常に選択不可になっています。

下位ネットへ

下位ネットへ移動します。左のツリービューも連動します。1つのネットが選択されている場合のみ有効になります。統計情報タブでは常に選択不可になっています。

切り取り

常に選択不可になっています。

コピー

選択しているジョブ、ネットの情報をテキスト形式でクリップボードにコピーします。

貼り付け

常に選択不可になっています。

削除

常に選択不可になっています。

5.4.5.6. ジョブレポート定義の選択ダイアログ

[ファイル]→[ジョブレポート定義]メニューを選択して表示される、ジョブレポート定義の選択ダイアログを下記の図に、内容を下記の表に示します。

../../_images/image526.jpg

図 5.474 ジョブレポート表示条件ダイアログ

表 5.428 ジョブレポート表示条件ダイアログ

項目

内容

「ドメイン」選択プルダウンリスト

ジョブレポートに表示する対象のドメインを選択します。選択対象として表示されるのは、現在千手ブラウザで接続しているドメインの一覧です。1度に1つのドメインしか表示できません。

「ジョブレポート」フレームの一覧リスト

ジョブレポートで表示するジョブレポート定義を選択します。選択対象として一覧にリスト表示されるのは「ドメイン」選択プルダウンメニューで選択された千手ドメインに登録してあるジョブレポート定義のみです。

5.4.5.7. ジョブレポート表示条件ダイアログ

[ファイル]→[表示条件の選択]メニューを選択して表示される、表示条件の選択ダイアログを下記の図に、内容、省略できるかどうかを下記の表に示します。

../../_images/04_JobReport_ShowTerms_Dialog.jpg

図 5.475 ジョブレポート表示条件ダイアログ

表 5.429 ジョブレポート表示条件ダイアログ

項目

内容

「ドメイン」選択プルダウンリスト

ジョブレポートに表示する対象のドメインを選択します。選択対象として表示されるのは、現在千手ブラウザで接続しているドメインの一覧です。1度に1つのドメインしか表示できません。

「稼働履歴」チェックボックス

稼働履歴タブの表示データを変更しない場合はチェックを外します。

稼働履歴:「運用日付」フィールド

稼働履歴タブに表示したい運用日付を入力します。

稼働履歴:「運用日付」の日付入力ボタン

稼働履歴タブに表示したい運用日付を選択するための日付選択ダイアログを表示します。

稼働履歴:「フレーム名」フィールド

稼働履歴タブに表示したいフレーム名を入力します。

稼働履歴:「フレーム名」のリストボタン

稼働履歴タブに表示したいフレーム名を選択するためのフレーム名一覧ダイアログを表示します。

「統計情報」チェックボックス

統計情報タブの表示データを変更しない場合はチェックを外します。

統計情報:「運用日付」フィールド(開始)

統計情報タブに表示する運用日付の範囲の開始日付を入力します。

統計情報:「運用日付」フィールド(開始)入力ボタン

統計情報タブに表示する運用日付の範囲の開始日付を選択するための日付選択ダイアログを表示します。

統計情報:「運用日付」フィールド(終了)

統計情報タブに表示する運用日付の範囲の終了日付を入力します。

統計情報:「運用日付」フィールド(終了)入力ボタン

統計情報タブに表示する運用日付の範囲の終了日付を選択するための日付選択ダイアログを表示します。

統計情報:「グラフの種類」プルダウンリスト

表示するグラフの種類を以下の項目より選択します。
  • 折れ線グラフ:統計情報タブで対象データを折れ線グラフで表示します。

  • 棒グラフ:統計情報タブで対象データを棒グラフで表示します。

  • 積み上げ折れ線グラフ:統計情報タブで対象データを積み上げ折れ線グラフで表示します。

  • 積み上げ棒グラフ:統計情報タブで対象データを積み上げ棒グラフで表示します。

統計情報:「追加」ボタン

統計情報タブで表示するデータを追加を行います。最大で10件まで追加可能です。

統計情報:「コピー」ボタン

統計情報タブで表示するデータのコピーを行います。

統計情報:「変更」ボタン

統計情報タブで表示するデータの変更を行います。

統計情報:「削除」ボタン

統計情報タブで表示するデータの削除を行います。

統計情報:「ジョブ/ネット/フレーム」リスト

統計情報タブで表示するデータのリストを表示しています。


表 5.430 ジョブレポート表示条件ダイアログの入力フィールド

フィールド

使用可能な文字

文字数

省略

「フレーム名」

半角英数字、'-'、'_'、'+'、全角文字
[WINM] 半角英小文字を使用する事はできません。

32文字まで

不可

「運用日付」

半角数字

8文字固定

ジョブレポート表示条件ダイアログで統計情報に表示するフレーム、ネット、ジョブの追加、変更、コピーボタンを押して表示されるジョブレポート統計情報用フレーム/ネット/ジョブダイアログを下記の図に、内容、各入力フィールドの使用可能な文字、文字数の制限、省略可/不可を下記の表に示します。

../../_images/04_JobNetFrame_Dialog_for_JobReport.jpg

図 5.476 ジョブレポート統計情報用フレーム/ネット/ジョブダイアログ

表 5.431 ジョブレポート統計情報用フレーム/ネット/ジョブダイアログ

項目

内容

「種類」プルダウンリスト

追加、コピーで表示項目を追加及び変更時に表示項目を変更する種類をジョブ、ネット、フレームから選択します。

「フレーム名」フィールド

フレーム名を入力します。

「フレーム名」選択ボタン

フレーム名を選択するためのフレーム名一覧ダイアログを表示します。

「親ネット名」フィールド

種類でジョブを選択した場合、親ネット名を入力します。フレーム、ネット選択時は不活性になっています。

「親ネット名」選択ボタン

親ネット名を選択するためのネット名一覧ダイアログを表示します。

「ジョブ/ネット名」フィールド

種類でジョブを選択した場合はジョブ名を、ネットを選択した場合はネット名を表示します。フレームを選択した場合は不活性になっています。

「ジョブ/ネット名」選択ボタン

ジョブ/ネット名を選択するための一覧ダイアログを表示します。種類でジョブを選択している場合はジョブの一覧が、ネットを選択している場合はネットの一覧が表示されます。

「色を指定」チェックボックス

グラフの表示色を指定する際にチェックします。チェックしない場合は、表示色は自動的に選択されます。

注釈

ジョブの一覧に表示されるジョブ名の一覧には分岐ジョブは表示されません。分岐ジョブ名を「ジョブ/ネット名」フィールドに反映させたい場合は、分岐ジョブ名を「ジョブ/ネット名」フィールドに直接入力してください。

表 5.432 ジョブレポート統計情報用フレーム/ネット/ジョブダイアログの入力フィールド

フィールド

使用可能な文字

文字数

省略

「フレーム名」

半角英数字、'-'、'_'、'+'、全角文字
[WINM] 半角英小文字を使用する事はできません。

32文字まで

不可

「親ネット名」

半角英数字、'-'、'_'、'+'、'#'、'@'、全角文字
[WINM] 半角英小文字を使用する事はできません。

32文字まで

不可

「ジョブ/ネット名」

32文字まで

不可

5.4.5.8. ジョブ検索ダイアログ

[編集]→[検索]メニューを選択して表示される、ジョブ検索ダイアログを下記の図に、内容、各入力フィールドの使用可能な文字、文字数の制限、省略可/不可を下記の表に示します。

../../_images/image529.jpg

図 5.477 ジョブ検索ダイアログ

表 5.433 ジョブ検索ダイアログ

項目

内容

検索対象プルダウンリスト

検索対象をジョブ/ネット/フレームの中から選択します。

「検索文字列」フィールド

検索する文字列を指定します。

「大文字と小文字を区別する」チェックボックス

検索時に英大文字と英小文字を区別するかどうかを指定します。

「検索方向上/下」チェックボックス

現在選択中のオブジェクトからの検索方向を指定します。

「運用日付」プルダウンリスト

絞り込み検索を行う運用日付を選択します。

「実行システム」プルダウンリスト

絞り込み検索を行う実行システムを選択します。

「フレーム」プルダウンリスト

絞り込み検索を行うフレームを選択します。


表 5.434 ジョブ検索ダイアログの入力フィールド

フィールド

使用可能な文字

文字数

省略

「検索する文字列」

すべての文字

-

不可

5.4.5.9. ジョブレポートのコマンド

ジョブレポートで表示する履歴データはデータベースで管理しています。履歴データを管理するコマンドには履歴データの保存期間の変更を行う千手データベースサーバー設定コマンドと、履歴データを削除するジョブ稼働履歴削除コマンドの2つがあります。

5.4.5.9.1. 千手データベースサーバー設定コマンド

ジョブ/ネット/フレームの履歴データは運用日付ごとに作成された各テーブルに蓄積されデータベースで管理を行っています。履歴データは、保存期間の上限を設定することが可能です。保存期間を終了した履歴データは自動的に削除されます。千手データベースサーバーインストール時の履歴データの保存期間は12か月間、自動削除機能はONとなっています。これらの値はsj_change_db.com(UNIX/LINUX)/sj_change_db.cmd(WIN)コマンドで変更することが可能です。

  • 履歴データ量について

    ジョブレポート機能使用時の1運用日付分の履歴データ量は、以下の計算式を用いて概算容量を見積ることができます。

    履歴データ量=約180byte×1運用日付に含まれるフレーム/ネット/ジョブの合計数

    例えば、実行システムの中に5フレーム、100ネット、1000ジョブが含まれている場合の1運用日付分の履歴データ量は以下のようになります。

    約180byte ×( 5 + 100 + 1000 ) = 198900byte(約194kbyte)

    1運用日付あたり約194kbyteの履歴データが保存されていきます。

  • 履歴データの保存期間変更

    履歴データの保存期間の詳細な変更方法は、 インストールガイド の 履歴データ保存期間の変更 、 履歴保存期間の変更 を参照して下さい。ただし、保存期間の上限を増やした場合、データ量が増加してデータベースのパフォーマンスの劣化やリソースを圧迫する可能性があるため、性能面及びマシンリソースの注意が必要です。

  • 履歴データ自動削除機能変更

    未来日付でマシンを稼働させたときに、それまで蓄積された履歴データを削除しないようにするため、履歴データを自動的に削除する機能を停止することが可能です。(詳細は、インストールガイド の 履歴データ保存期間の変更 、 履歴保存期間の変更 を参照。)

    「ジョブスケジュール」画面が表示されますので、"2"を入力して下さい。

    「※1(ON) or 0(OFF)で入力してください」と表示されますので、"0"を入力して下さい。「よろしいですか?(y/n)」と表示されますので、「y」を入力して上記の設定を反映させて下さい。

    ※1(ON) or 0(OFF)で入力してください
    >> 0
    
    履歴データ自動削除機能を 1 から 0 に変更します。
    よろしいですか?(y/n)  >> y
    

    上記設定を行うと、再びジョブスケジュールの設定画面に戻るので、"3"を入力して初期メニューに戻って下さい。

5.4.5.9.2. ジョブ稼働履歴削除コマンド

通常、履歴データは保存期間を基に、定期的に自動削除を行っていますが、不必要になったデータや、未来日付でジョブをテスト稼働させた時に保存された履歴データなどを削除したい場合は、ジョブ稼働履歴削除コマンドでデータの削除を行うことが可能です。

詳細は、 千手コマンド一覧 を参照して下さい。