6.4. ツール

ここでは、千手システムが提供する各種ツールについての説明を行います。

6.4.1. グラフモニタ

6.4.1.1. グラフモニタの概要

グラフモニタでは、モニタリングで登録した監視タスクの履歴データをグラフ化し、分析、参照することができます。グラフモニタに表示されるグラフには、時系列グラフ、監視タスク系列グラフがあります。また、グラフの種類では棒グラフ、折れ線グラフ、積上げ棒グラフ、積上げ折れ線グラフ、円グラフを表示する事ができます。

このモニタにより各監視タスクの履歴データの変化を時系列に把握したり、監視タスクごとに傾向分析したりする事ができます。

グラフモニタでは、表示情報を随時更新しません。最新の監視情報を表示するには「最新の情報に更新」を行う必要があります。

グラフモニタの設定を変更する場合は、グラフ定義のプロパティを開きグラフ表示の設定を変更するか、グラフモニタ画面のグラフのプロパティから設定を変更する事ができます。

6.4.1.2. グラフモニタの画面概要

グラフモニタの画面概要を下記の図に示します。

グラフモニタ画面は、メニュー、ツールバー、アウトプットビュー、ステータスバーを持ちます。

ツールバー、アウトプットビューはドッカブルバーで、位置及びサイズを変更することができます。

ステータスバーには、ブラウザ画面に関連する情報が表示されます。接続しているドメイン名、ユーザー名、ユーザーグループ名などが表示されます。

アウトプットビューについては、千手ブラウザと同じ機能です。詳しくは 千手ブラウザの基本構成 を参照して下さい。

../_images/image112.jpg

図 6.48 グラフモニタ

表 6.27 グラフモニタ

項目

説明

「期間」フィールド

グラフモニタに表示されているデータが取得された期間を表示します。

「横軸」フィールド

グラフに指定されている横軸を表示します。

「グラフのプロパティ」ボタン

選択したグラフ定義の登録内容を確認・変更することが可能です。ボタンをクリックすると、グラフのプロパティ画面が表示されます。

「説明」フィールド

グラフに関する説明を表示します。

「選択された点の情報」フレーム

選択された点の情報が表示されるフレームです。

「カテゴリ名」フィールド

選択された点の監視タスクのカテゴリ名が表示されます。

「監視タスク」フィールド

選択された点の監視タスクの名称が表示されます。

「設定情報」フィールド

選択された点の監視タスクに設定してあるパラメータの設定情報が表示されます。

「監視対象ノード」フィールド

選択された点の監視タスクの監視対象ノードが表示されます。

「値」フィールド

選択された点のデータ値が表示されます。

「サマリ方法」フィールド

選択された点の監視タスクのサマリ方法が表示されます。

「取得日時」フィールド

選択された点のデータ値の取得日時が表示されます。

「傾き」フィールド

増減傾向予測モデルの傾きが表示されます。増減変化の速さを表しています。

「予測しきい値」フィールド

増減傾向予測が行われるためのしきい値が表示されます。

「予測しきい値到達日時」フィールド

増減傾向予測と予測しきい値から算出された、予測しきい値到達日時が表示されます。(※1)

※1 予測しきい値到達日時が3000年1月1日以降になった場合、またはグラフ表示開始日時よりも前の日時になった場合、「予測しきい値到達日時」フィールドに「範囲外」が表示されます。

6.4.1.3. グラフモニタのメニュー

グラフモニタのメニューを下記の図に示します。

メニューには、[ファイル]メニュー・[編集]メニュー・[表示]メニュー・[ヘルプ]メニューがあります。

../_images/image1141.jpg

図 6.49 グラフモニタのメニュー

6.4.1.3.1. グラフモニタ([ファイル]メニュー)

グラフモニタの[ファイル]メニューを下記の図に、内容を下記の表に示します。

../_images/image1161.jpg

図 6.50 グラフモニタの[ファイル]メニュー

表 6.28 グラフモニタの[ファイル]メニュー

メニュー

アクション

グラフ

表示対象となるグラフ定義を選択する、「グラフの選択ダイアログ 」を表示します。

送る→ファイル

グラフの数値データの内容を以下の形式でファイルに書き込みます。
  • テキスト(スペース区切り):取得日時と結果はスペースで区切られています。

  • テキスト(タブ区切り):取得日時と結果はタブで区切られています。

  • CSV(カンマ区切り):取得日時と結果はカンマで区切られています。

  • HTML:HTML形式で出力されます。

送る→メール受信者

グラフの数値データの内容をテキスト形式ファイルにし、メールに添付して送信します。前提条件として、Microsoft ExchangeなどのMAPI(Messaging Application Programming Interface)と互換性のあるメールシステムの設定が必要です。

印刷

グラフモニタに表示されているグラフイメージを印刷します。

アウトプットビュー印刷

アウトプットビューの内容をテキスト形式で印刷します。

プリンタの設定

プリンタ設定用のダイアログを表示します。

閉じる

グラフモニタウィンドウを閉じます。

6.4.1.3.2. グラフモニタ([編集]メニュー)

グラフモニタの[編集]メニューを下記の図に、内容を下記の表に示します。

../_images/image1181.jpg

図 6.51 グラフモニタの[編集]メニュー

表 6.29 グラフモニタの[編集]メニュー

メニュー

アクション

切り取り

常に選択不可になっています。

コピー

グラフをクリップボードにビットマップ形式でコピーします。

貼り付け

常に選択不可になっています。

削除

常に選択不可になっています。

すべて選択

常に選択不可になっています。

数値データをコピー

グラフの数値データをクリップボードにテキスト形式でコピーします。

6.4.1.3.3. グラフモニタ([表示]メニュー)

グラフモニタの[表示]メニューを下記の図に、内容を下記の表に示します。

../_images/image1201.jpg

図 6.52 グラフモニタの[表示]メニュー

表 6.30 グラフモニタの[表示]メニュー

メニュー

アクション

ツールバー

ツールバーの表示/非表示の切り替えを行います。

アウトプットビュー

アウトプットビューの表示/非表示の切り替えを行います。

ステータスバー

ステータスバーの表示/非表示の切り替えを行います。

ツールバーの設定

ツールバーの設定ダイアログを表示します。ツールバーには、メニューにある任意のメニュー項目が設定できます。

フォントの設定

フォントの設定ダイアログを表示します。

最新の情報に更新

グラフモニタの表示内容を最新の情報に更新します。

6.4.1.3.4. グラフモニタ([ヘルプ]メニュー)

グラフモニタの[ヘルプ]メニューを下記の図に、内容を下記の表に示します。

../_images/image1221.jpg

図 6.53 グラフモニタの[ヘルプ]メニュー

表 6.31 グラフモニタの[ヘルプ]メニュー

メニュー

アクション

バージョン情報

プログラムのバージョンを表示します。

6.4.1.4. グラフモニタのツールバー

グラフモニタのデフォルトのツールバーを下記の表に示します。

ツールバーに表示する項目は、 グラフモニタ([表示]メニュー) の「ツールバーの設定」を選択して出てくるダイアログで、自由に変更することができます。

表 6.32 グラフモニタのツールバー

アイコン

名前

アクション

../_images/image1231.jpg

最新の情報に更新

最新の情報に更新します。

6.4.1.5. グラフモニタのコンテキストメニュー

グラフモニタのコンテキストメニューを下記の図に示します。

コンテキストメニューはグラフ上の点を選択し右クリックすると表示されます。

../_images/image1251.jpg

図 6.54 グラフモニタのコンテキストメニュー

表 6.33 グラフモニタのコンテキストメニュー

項目

内容

ジョブ稼働状況

選択された点の時間に稼働していたジョブを確認する「ジョブ稼働状況ダイアログ」を表示します。「ジョブレポート」のライセンスが無い場合は不活性表示です。

ノードモニタ

ノードモニタを起動します。

バーチャルノードモニタ

バーチャルノードモニタを起動します。

構成ビューア

構成ビューアを起動します

6.4.1.6. グラフの選択ダイアログ

[ファイル]メニューの[グラフ]を選択して表示される画面を下記の図に、内容を下記の表に示します。

グラフモニタで表示するグラフを選択するダイアログです。

../_images/image1271.jpg

図 6.55 グラフの選択ダイアログ

表 6.34 グラフの選択ダイアログ

項目

内容

「ドメイン」選択プルダウンメニュー

グラフモニタで表示するグラフが登録してある千手ドメインを選択します。選択対象として表示されるのは現在接続中の千手ドメインのみです。

「グラフ」フレームの一覧リスト

グラフモニタで表示するグラフを選択します。選択対象として一覧にリスト表示されるのは「ドメイン」選択プルダウンメニューで選択された千手ドメインに登録してあるグラフ定義のみです。

6.4.1.7. ジョブ稼働状況ダイアログ

グラフ上の点を選択して右クリックで表示されるコンテキストメニューから、[ジョブ稼働状況]を選択して表示される画面を下記の図に、内容を下記の表に示します。

このダイアログで運用日付を選択し[OK]ボタンを押すと、選択された点のデータ値の取得日時に、監視タスクの監視対象ノードで稼働していたジョブの稼働状況の一覧が表示されます。

一覧に表示されるのは正常終了、異常終了したジョブのみで、稼働中/スキップ終了のジョブは表示されません。

../_images/image1291.jpg

図 6.56 ジョブ稼働状況ダイアログ

表 6.35 ジョブ稼働状況ダイアログ

項目

内容

「運用日付」フィールド

運用日付を指定します。

「運用日付」フィールドの日付入力ボタン

運用日付を指定するための、カレンダーダイアログを表示します。

注釈

千手データベースサーバーの分離構成環境ではジョブ稼働状況は表示されません。